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Safety Notices

CAUTION

A CAUTION notice denotes a haz-
ard. It calls attention to an operat-
ing procedure, practice, or the like 
that, if not correctly performed or 
adhered to, could result in damage 
to the product or loss of important 
data. Do not proceed beyond a 
CAUTION notice until the indicated 
conditions are fully understood and 
met. 

WARNING

A WARNING notice denotes a 
hazard. It calls attention to an 
operating procedure, practice, or 
the like that, if not correctly per-
formed or adhered to, could result 
in personal injury or death. Do not 
proceed beyond a WARNING 
notice until the indicated condi-
tions are fully understood and met.
Trademarks

Windows 2000®, Windows XP®, and 
Microsoft .NET Framework 1.1® are U.S. 
registered trademarks of Microsoft Corpo-
ration.

Installation Guides

You can find the installation guides for 
different components of the product on the 
product CD. Agilent recommends you to do 
not switch on the instrument before you 
have understood all the applicable 
installation instructions and have met all 
the installation prerequisites.

Where to find more information

You can find more information about 
Protocol Analyzer from the following link:

http://www.agilent.com/find/spt

You can also look for search a local contact 
for assistance on the following link:

http://www.http/agilent/find/assist
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Indicates warning or caution. If you 
see this symbol on a product, you 
must refer to the manuals for 
specific Warning or Caution 
information to avoid personal injury 
or damage to the product.

Frame or chassis ground terminal. 
Typically connects to the 
equipment’s metal frame.

Indicates hazardous voltages and 
potential for electrical shock.
Indicates that antistatic 
precautions should be taken.

Indicates hot surface. Please do 
not touch.

Indicates laser radiation turned on.

Safety requirements for electrical 
equipment for measurement, 
control, and laboratory use 
CAN/CSA C22.2 No. 1010.1 (1993) 
UL 3101, 3111 (First Editions) This 
equipment has also been evaluated 
to IEC 61010 edition 1 including 
amendments 1 and 2.
Notice for European Community: 
This product complies with the 
relevant European legal Directives: 
EMC Directive 89/336/EEC and 
Low Voltage Directive 73/23/EEC.

This is the symbol for an Industrial, 
Scientific, and Medical Group 1 
Class A product.
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This chapter introduces you to the Protocol Analyzer 
application and provides information on accessing and 
exiting the Protocol Analyzer GUI.
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Agilent Protocol Analyzer is an advanced verification system 
that allows you to capture data traffic generated by various 
protocols, such as PCI Express (PCIe), Advanced Switching 
Interconnect (ASI), and Fibre Channel (FC). This data, which 
you capture, you can view and analyze to identify problems, 
find their root cause, and troubleshoot them. This makes 
Protocol Analyzer a very effective tool to control as well as 
speed the development and testing of the PCIe, ASI, and FC 
protocols.

A brief list of features of Protocol Analyzer is given below:

• Enables you to perform root cause and performance 
analysis.

• Provides GUI for trigger setup, search, filter, and error 
detection.

• Provides a trigger sequencer with sophisticated trigger 
capabilities and storage qualifications.

• Provides 1 GB of trace memory.

• Provide x1, x2, x4, and x8 link widths with 2.5 Gbps.

• Provides non- intrusive traffic capturing.

• Provides easy visibility into a protocol transactions. For 
example, it displays the traffic activity, port link status, 
and trace content simultaneously. It also provides 
sophisticated and fast screen based traffic upload.

• Provides tabular traffic display that speeds the debug 
process.

• Provides multi- port display for better insight into your 
system.

• Captures training sequences, ordered sets, data link layer 
packets (DLLPs), and transaction- layer packets (TLPs) in 
both directions simultaneously.
NOTE Protocol Analyzer has two interfaces: GUI and API. This guide covers only 
the GUI aspect of the Protocol Analyzer application. For information on 
API, please refer to the online help.
Protocol Analyzer User Guide
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About Starting and Closing Protocol Analyzer
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Before you get started with Protocol Analyzer, you need to 
know how to access it.

In this section, you will learn about:

• Understanding Protocol Analyzer Session

• Accessing Protocol Analyzer

• Exiting Protocol Analyzer
Understanding Protocol Analyzer Session
In the context of Protocol Analyzer, a session represents the 
components, such as Controller PC, serial I/O modules, and 
probe, involved in a test. Session forms the basis of 
communication between the controller PC and the Serial I/O 
Modules. 

Figure 1 displays the components involved in a Protocol 
Analyzer session. It also displays that more than one client 
can be associated with one session.

Figure 1 Protocol Analyzer Sessions and Components

Remember the following points while starting and using a 
new Protocol Analyzer instance: 

• Starting a session establishes communication between the 
client and the controller PC, and also loads the necessary 
firmware on the desired serial I/O module. 
9
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• Ending a session clears the serial I/O module, thus 
enabling it to be used for a new session. 

• Protocol Analyzer does not enable you to lock a session. 
Therefore, it is possible for multiple Protocol Analyzer 
instances to concurrently access one session.
Accessing Protocol Analyzer

NOTE The controller PC does not protect against meaningless, or even 
conflicting requests. Therefore, it is recommended that only one user 
should own a particular session at a time.
Accessing Protocol Analyzer requires you to specify whether 
you want to connect to a new or an existing session, and the 
name of the server where you want to start the session. 
Accessing Protocol Analyzer also requires you to specify the 
port to use if you are trying to connect to a new session.

To specify all required inputs, Protocol Analyzer provides 
two dialog boxes: Select type of connection (Figure 2) and 
Port Selection (Figure 3).

Figure 2 Select type of connection dialog box

Table 1 briefly describes the components of the Select type 
of connection dialog box.
Protocol Analyzer User Guide
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Figure 3 displays the Port Selection dialog box.

Figure 3 Port Selection dialog box

Table 2 briefly describes the components of the Port 
Selection dialog box.

Table 1 Components of the Select type of connection dialog box

Component Description

Connect to existing 
session

Select Connect to existing session if you want to use 
an existing session of Protocol Analyzer on a known 
server.

Connect to new 
session

Select Connect to new session if you want to create a 
new Protocol Analyzer session on a known server.

Server Specifies the name or IP address of the server, where 
you want to start a new or join an existing Protocol 
Analyzer session. Its default value is localhost.

Get session list Click Get session list to retrieve a list of existing 
Protocol Analyzer sessions from the server you 
specified in the Server text field. This button works 
only if you have selected the Connect to existing 
session option.

Session list Displays a list of sessions existing on the server you 
specified in the Server text field.

Start Click Start to start a new Protocol Analyzer instance.

Exit Click Exit to close the dialog box without starting the 
Protocol Analyzer application.

Help Click Help to display the online help.
11
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Table 2 Components of the Port Selection dialog box

Component Description

Module The Module column provides a list of modules in the 
form of check boxes. These check boxes are organized 
under the expandable list of chassis to which they 
belong. Here, select a module on which you want to start 
a new session. 
A module, which is already associated with a session, 
appears disabled. 

Type The Type column enables you to select the type of port to 
use.

# Ports The # Ports column displays the number of ports for 
each module.

License The License column displays the license details of each 
module.

Status The Status column displays the status of each module. 
This column displays the following messages:
• Rebooting: This message indicates that the serial I/O 

module is restarting.
• Ready: This message indicates that you can now add 

port to the session.
• Session_Name: Session_Name is the name of the 

session, such as PCIEExerciser GUI. This message 
indicates that the Session_Name session is now 
connected with the port.

Select Ports to use Select the port to use from the Select Ports to use list 
box.

OK Click OK to start an instance of Protocol Analyzer on the 
selected port.
NOTE To find out more about the licensed software: 

• Click File > Software Packages. This displays the Software Package 
Management dialog box. Here, you can view a list your current licensed 
software in the Installed Software Packages section.
To access Protocol Analyzer

1 On the Windows task bar, click Start > Programs > 
Agilent System Protocol Tester > Protocol Analyzer.

The Select type of connection dialog box appears.
Protocol Analyzer User Guide
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2 Do one of the followings:

a Click Connect to existing session to use an existing 
Protocol Analyzer session.

b Click Connect to new session to start a new Protocol 
Analyzer session.

3 Type in the name or IP address of the server, where you 
want to start a new or join an existing Protocol Analyzer 
session, in the Server text field.

4 If you are trying to use an existing Protocol Analyzer 
session, do the following:

a Click Get session list. A list of sessions that are 
currently running on the server specified in the Server 
text field is displayed in Session list.

b Select the required session from Session list.

c Click Start. The main Protocol Analyzer window 
appears.

5 If you are trying to create a new Protocol Analyzer 
session, do the following:

a Click Start. The Port Selection dialog box appears.

b Select a module check box from the Module column.

c Select an appropriate option from the Type drop- down 
list.

d Click OK. The main Protocol Analyzer window appears.
Exiting Protocol Analyzer
You can exit from the Protocol Analyzer application by 
closing the opened trace file and the Protocol Analyzer 
window.

In this section, you will learn:

• To close a trace file

• To exit Protocol Analyzer

To close a trace file

• Click File > Close.

To exit Protocol Analyzer

1 Click File > Exit.

The Session still open message box appears.
13
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2 Do one of the following:

a Click Yes. This closes the Protocol Analyzer window 
and also removes the associated session.

b Click No. This closes the Protocol Analyzer window 
without removing its associated session.
NOTE Closing a session automatically makes all the GUI interfaces, which are 
connected to it, inaccessible.
Protocol Analyzer User Guide
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Getting Started

About the Protocol Analyzer Components    16

About Loading and Saving the Protocol Analyzer Data    27

This chapter briefly introduces you to the main screen 
components of the Protocol Analyzer application. This 
chapter also introduces you to loading and saving the 
Protocol Analyzer data.
15Agilent Technologies
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About the Protocol Analyzer Components
16
Protocol Analyzer provides various components that you can 
use to access its various features.

Figure 4 displays the Protocol Analyzer application window 
with its main components.
        

Menu Bar

Toolbar

Measurement Area

Port Overview Pane

Traffic Overview Pane

Packet View

Decode View Pane

Status Bar
Figure 4 Protocol Analyzer window

This section covers the following topics:

• Protocol Analyzer Window

• Menu Bar

• Toolbar

• Panes
Protocol Analyzer User Guide
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The main components of the Protocol Analyzer window are 
briefly described below:

• Menu Bar and Toolbar: They provide easy and quick 
access to the features of the Protocol Analyzer 
application.

• Measurement Area: It displays the time gap between two 
markers. 

• Packet View: It displays detailed information about all 
the traced packets. 

• Panes: They display information about traffic, hardware 
status, decoded form of the packet data, and the port on 
which Protocol Analyzer is running.

• Status Bar: It displays the current status of the various 
Protocol Analyzer activities, such as if it is online or 
offline, and if it is running or stopped.
Menu Bar

NOTE Menu bar, toolbar, and panes are described separately in the following 
sections. For more information on the Measurement area and the Packet 
view, refer to Customizing Protocol Analyzer on page 33.
In Protocol Analyzer, menu bar provides the following 
menus:

• File menu

• Edit menu

• View menu

• Capture menu

• Help menu

File menu

Table 3 provides a brief description of the File menu 
commands.
17
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Edit menu

Table 4 provides a brief description of the Edit menu 
commands.

Table 3 File menu commands

Menu command Description

Open Displays the Open dialog box that enables you to 
open the configuration (.xml) file and/or the binary 
(.pad) file. 

Save As Displays the Save As dialog box that enables you to 
save the trace to a file in XML and binary formats.

Text Export Displays the Save As dialog box that enables you to 
save the trace to a file in text format.

Close Closes the currently active tab in the Packet view.

Page Setup Displays the Page Setup dialog box that enables you 
to specify the page settings for printing the trace.

Print Displays the Print dialog box that enables you to print 
the traced data.

Software Packages Displays the Software Package Management dialog 
box that shows you the already installed software 
and provides a list of new software to be installed. It 
not only displays licenses, but also allows you to add 
new licenses.

Exit Closes the Protocol Analyzer application.

Table 4 Edit menu commands

Menu command Description

Copy Enables you to copy the Protocol Analyzer data to 
clipboard. For example, you can copy one or more data 
packet records and paste them in Protocol Exerciser to 
generate same or similar type of data packets.

Find Displays the Find dialog box that enables you to specify 
the criteria to search data packets.

Find Previous Searches the previous occurrence of the data packet 
using the search criteria specified in the Find dialog box.

Find Next Searches the next occurrence of the data packet using 
the search criteria specified in the Find dialog box.

New Marker Creates a new marker at the beginning of a selected data 
packet or frame.
Protocol Analyzer User Guide
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View menu

Table 5 provides a brief description of the View menu 
commands.

Delete Marker Removes the selected marker.

Marker Properties Displays the Properties of marker dialog box that you can 
use to view and modify the properties of a marker.

Table 5 View menu command

Menu command Description

Filter Provides sub-menu commands that enable you to create 
filters on data packets trace, as well as remove filters.

Goto Provides sub-menu commands that enable you to move 
on to a trigger, marker, or a particular data packet record 
in the Packet view.

Zoom Enables you to set the screen resolution of the data 
packet records shown in the Packet view.

Expand All Packets Expands all the data packet records to show the details 
of their fields.

Collapse All Packets Collapses all the data packets records to hide the details 
of their fields.

Record Decode 
View

Displays the Record Decode pane.

Single Line Decode 
View

Displays the Single Line Decode pane.

Port Overview Displays the Port Overview pane.

Preferences Displays the Preferences dialog box.

Port Management Displays the Port Selection dialog box that enables you to 
select the ports of a module for your test application.

Default Window 
Arrangement

Resets the GUI settings of the Protocol Analyzer 
application to default.

Realtime Statistics Displays the Realtime Statistics dialog box that shows 
the graphical representation of the data traffic.

Table 4 Edit menu commands

Menu command Description
19
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Capture menu

Table 6 provides a brief description of the Capture menu 
commands.

Capture

Help menu

Table 7 provides a brief description of the Help menu 
commands.

Table 6 Capture menu commands

Menu commands Description

Start Starts capturing data packets.

Stop Stops capturing data packets.

Trigger Setup Displays the Trigger Setup dialog box.

Hardware Setup Displays the Hardware Setup pane.

Table 7 Help menu commands

Menu command Description

Help Topics Displays the online help for Protocol Analyzer.

Session 
Information

Displays the Session Information message box with the 
current session information.

About Displays the information about the System Protocol 
Tester system.
Toolbar
Toolbar provides a quick access to the features of the 
Protocol Analyzer application (Figure 5).

Figure 5 Toolbar

Table 8 specifies the names of all toolbar icons.
Protocol Analyzer User Guide
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Table 8 Toolbar icons

Icon Name

Start hardware capturing

Stop hardware capturing

Show Trigger Setup

Show port setup

Open trace file

Save trace to file

Print

Print preview

Find packets

Find previous occurrence

Fine next occurrence

Goto marker

Goto trigger

Filter packet display

Disable all packet filters

Zoom factor for packet views
21
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Filter all Skip Ordered Sets

Filter all Update Flow control Packets and Skip 
Ordered Sets

Table 8 Toolbar icons

Icon Name
Panes
Protocol Analyzer provides the following panes:

• Port Overview

• Traffic Overview

• Hardware Status

• Decode View

Port Overview

To access the Port Overview pane:

• Click View > Port Overview.

The Port Overview pane appears (Figure 6).

Figure 6 Port Overview pane

Port Overview displays the data of the ports that are 
connected with the current Protocol Analyzer session. A 
brief description of this data is given in Table 9.

Table 9 Port Overview pane

Column Description

D This column provides a check box for each port connected 
to the current Protocol Analyzer session. Selecting a check 
box displays the captured data of the port in the Packet 
view.
Protocol Analyzer User Guide
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Traffic Overview

To access the Traffic Overview pane:

• Click View > Traffic Overview.

The Traffic Overview pane appears (Figure 7).

R This column displays a list of one or more check boxes for 
those ports, which are connected with the current Protocol 
Analyzer session. Selecting a check box ensures that the 
data for its corresponding port will be captured whenever 
you will run Protocol Analyzer.

Port This column displays the ID of those ports, which are 
connected with the current Protocol Analyzer session.

Speed This column displays the speed at which the port will 
capture the data.

Name This column displays the port name. This column also 
allows you to change port name by just clicking the existing 
name and then retyping the new name. This is useful if you 
are working with multiple ports, and each port is connected 
to a different DUT.

Link This column displays the following messages to show the 
status of the link:
• No Laser: This message means that laser is turned off 

and the port is not capturing data. This message is 
shown with a red colored bullet ( ). This message 
applies to the Fibre Channel protocol only.

• LOS: This message means loss of synchronization and 
the port is not capturing data. This message is shown 
with a red colored bullet ( )

• OK: This message means that a connection has been 
established between a probe card and DUT. This 
message is shown with a green colored bullet ( ).

Records This column displays the number of records captured in the 
buffer.

Trigger This column displays the most recently applied trigger.

Activity This column shows the level of data rate using a straight 
line graph. In this method, a line is shown at the top of the 
column for the full level of date rate, and line is shown in the 
center of the column for the half level of data rate.

Table 9 Port Overview pane

Column Description
23
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Figure 7 Traffic Overview pane

The Traffic Overview pane displays the following 
information:

• Type: This column displays the packets that belong to the 
underlying protocol, such as PCI Express, Advanced 
Switching Interconnect (ASI), or Fibre Channel. Also, 
these packets are arranged by their type, such as TLP and 
DLLP.

• Count: This column displays the number of occurrences 
of each packet in the trace.

• Filter out: This column displays check boxes for each 
packet. These check boxes are enabled only for those 
packets which were found in the trace. If you want to 
filter out any packet from the future traces, select its 
corresponding Filter out check box.

Hardware Status

To access the Hardware Status pane:

• Click View > Hardware Status.

The Hardware Status pane appears (Figure 8).
Protocol Analyzer User Guide



Getting Started 2

Protocol Analyzer User Guide
Figure 8 Hardware Status pane

The Hardware Status pane displays the following 
information:

• General: This section shows information about Protocol 
Analyzer, such as if it is triggered or not, and whether it 
is running or not. This section also shows the percentage 
of trace memory filled and the status of the counters (C1 
and C2) that Protocol Analyzer provides for triggers.

• Link specific: This section shows the status information 
of the link width, lane reversal, descrambler, and polarity 
reversal.

Decode View

The Decode View pane displays the detailed data of the 
packet you selected in the Packet view. It is named as 
Decode View, because it displays the packet data in 
hexadecimal as well as in its decoded form.

Decode View has two nested panes: 

• Record Decode: It displays the decoded data in a vertical 
record hierarchy format. You can access it by clicking the 
Record Decode View menu command in the View menu.
25
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• Single Line Decode: It wraps the decoded data, for each 
row of hexadecimal data, in a single line. You can access 
it by clicking the Single Line Decode menu command in 
the View menu.

Figure 9 displays the Decode View panes.

Figure 9 Decode View panes

         Record Decode Single Line Decode
Protocol Analyzer User Guide



Getting Started 2
About Loading and Saving the Protocol Analyzer Data
Protocol Analyzer User Guide
Before starting to use Protocol Analyzer, it is important to 
understand how to maintain the data that you have 
analyzed. Protocol Analyzer provides features that allow you 
to save the analyzed data to a file and load it back to the 
application.

In this section, you will learn about:

• Saving the Data

• Loading the Data
Saving the Data
There are two ways to save the Protocol Analyzer data. One 
way allows you to save the data in the XML and binary 
format, and the other way allows you to save the data in 
text format.

In this section, you will learn about:

• Saving the Data in XML and Binary Format

• Saving the Data in Text Format

Saving the Data in XML and Binary Format

When you try to save the data in XML and binary format, 
the GUI settings of the Protocol Analyzer application are 
saved in the .xml file, and the trace data is saved in the 
.pad (binary) file.

You do not have to create a .pad file separately. It is 
automatically created by Protocol Analyzer while creating the 
XML file. 

For .pad files, Protocol Analyzer uses the following naming 
convention:

<XML_FileName><Module_Number>_<Port_Number>.pad

For example, you create an XML file named TraceData.xml to 
save the data of the module 102 and the port 1. As a 
consequence, Protocol Analyzer creates the following .pad 
file:

TraceData102_1.pad
27
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To save the data in XML and binary format:

1 Select File > Save As.

The Save As dialog box displays (Figure 10).
Figure 10 Save As dialog box - XML and Binary Format

2 Browse to the location where you want to save the data.

3 Type in the name of the file in the File name text field.

4 Select Protocol Analyzer files (*.xml) from the Save as 
type drop- down list.

5 Expand the Port check box list. A nested check box list 
of ports, to which the current Protocol Analyzer session is 
connected, is displayed.

6 Select the desired port.

7 Select the Setup check box if you want to save the setup 
information.

8 Expand Range. This displays a list of option buttons to 
specify the data range to be saved.
Protocol Analyzer User Guide
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9 Do one of the following:

a Select Full Range to save the complete traced data.

b Select Records to save only a range of packet records. 
Here, you also need to specify the start range and end 
range of records in the From and To text boxes.

c Select Markers to save a range of records between two 
markers. Here, you also need to specify the starting 
and ending markers in the From and To text boxes.

10 Click Save to save the Protocol Analyzer data.

Saving the Data in Text Format

Saving the data in text format creates a .csv file that 
contains the packet data in decoded form. 

Some important points about the resulting text file are:

• All entries in this file are separated by semicolon.

• The first line lists field names, which are enclosed in 
double- quotes.

• All the following lines are the field values.

• Field names in the text file matches the collapsed view of 
the columns on screen.

• Second line onwards, each line represents a single packet 
data.

• All lines contain same number of semicolons. If there is 
an empty field, it is represented by an empty string 
followed by a semicolon.

An example of how data is saved in a text file is given 
below:

  "Channel";"Rec Num";"Timestamp";"Type";"Address";"Data";

  Upstream;15310;2512100;Memory Read;00 10 00 00;;

  Downstream;15311;2512120;ACK;;;

The advantage of saving the data in text format is that you 
can edit the data using any text editor application. You can 
also load it into Microsoft Excel or any other application for 
further processing.
NOTE Microsoft Excel has a restriction of 65536 lines. Therefore, you should split 
the files that are larger than this limit.
29
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To save the data in text format:

1 Click File > Text Export.

The Save As dialog box appears (Figure 11).
Figure 11 Save As dialog box - Text Format

2 Browse to the location where you want to save the data.

3 Type in the name of the file in the File name text field.

4 Select Protocol Analyzer files (*.csv) from the Save as 
type drop- down list.

5 Expand the Port check box list. A nested check box list 
of ports, to which the current Protocol Analyzer session is 
connected, is displayed.

6 Select the desired port.

7 Expand Range. This displays a list of option buttons to 
specify the data range to be saved.

8 Do one of the following:

a Select Full Range to save the complete trace data.

b Select Records to save only a range of packet records. 
Here, you also need to specify the start range and end 
range of records in the From and To text boxes.

c Select Markers to save a range of records between two 
markers. Here, you also need to specify the starting 
and ending markers in the From and To text boxes.

9 Click Save to save the Protocol Analyzer data.
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Loading the Data

NOTE The performance of the process, which saves data in text format, degrades 
with the increasing size of trace. For example, it takes more than 3 hrs to 
save the data in text format for 1 GB of trace.
Once you have saved the trace data to a file, you can open 
it to load it again in Protocol Analyzer. You generally do this 
to compare the previously captured data with the data you 
have just captured. You can also load the already captured 
data to modify it and verify its behavior by comparing the 
resulting trace files.

Protocol Analyzer enables you to load the data only from the 
XML file and/or the binary file. It does not allow you to load 
the data from the text (.csv) file.

To Load the Data in Protocol Analyzer:

1 Click File > Open.

The Open dialog box appears (Figure 12).
Figure 12 Open dialog box
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2 Do one of the following:

a Click Configuration only if you want to load the 
contents of the XML file without loading the binary file 
(.pad) it references.

b Click Data only if you want to load the contents of the 
binary file without loading the contents of the XML 
file.

c Click Both if you want load the contents of the XML 
and binary files.

3 Browse to the target location and select the desired file.

4 Click Open to load the data from selected file.
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Customizing Protocol Analyzer

Managing Windows    34

Setting Preferences    36

Marking Data Packets    42

This chapter provides information on how to manage floating 
windows and set the preferences for the Protocol Analyzer 
GUI. This chapter also provides information on how to 
create, edit, use, and delete markers.
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Managing Windows
34
The main Protocol Analyzer window contains many floating 
windows. These windows can float anywhere on the desktop, 
or you can dock them together with other windows on the 
main Protocol Analyzer window. In the default window 
arrangement, all windows are properly docked on the main 
Protocol Analyzer window.

In this section, you will learn:

• To Display a Floating Window

• To Hide a Floating Window

• To Auto- Hide a Floating Window

• To Change a Docked Window to a Floating Window

• To Dock a Floating Window

• To Set the Default Windows Arrangement
To Display a Floating Window
• Click View > menu_command_for_floating_window.

Here, menu_command_for_floating_window represents 
the name of the menu command to access the floating 
window. For example, Port Overview is a floating window. 
To display it, click the View > Port Overview menu 
command.
To Hide a Floating Window
• Click the  icon on the title bar of the floating window.

If a floating window is displaying, then you hide it also 
by again clicking its menu command in the View menu.
To Auto-Hide a Floating Window
• Click the  icon on the title bar of the floating window.

Doing this automatically hides the floating window when 
you are not using it. This also displays a new  icon on 
the title bar of the floating window.

To display the window again, place the cursor over the 
tab displayed for the hidden window, or click its menu 
command in the View menu.
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To Change a Docked Window to a Floating Window
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• Double- click the title bar of the docked window.
To Dock a Floating Window
• Double- click the title bar of the floating window.
To Set the Default Windows Arrangement
• Click Window > Default Window Arrangement.
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Setting Preferences
36
By default, Protocol Analyzer displays packet data using 
predefined column, field, time format, and color settings. 
There may be a situation when you want to make some 
changes to these predefined settings to match your data 
display needs. To make such changes, Protocol Analyzer 
provides the Preferences dialog box (Figure 13). This dialog 
box allows you to make changes to the way data packets are 
displayed in the Packet view.

To access the Preferences dialog box:

• Click View > Preferences.

The Preferences dialog box appears (Figure 13).

Figure 13 Preferences dialog box

Table 10 briefly describes the common components of the 
Preferences dialog box.

Table 10 Components of the Preferences dialog box

Component Description

General This tab enables you to apply line wrap to the content 
displayed, and specify the time format to be used to 
display the timestamp details in the Packet view.
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In this section, you will learn about:

• Setting Up Line Wrap and Time Format

• Setting Columns

• Setting Subcolumns

• Setting Colors

View Columns This tab enables you to select a protocol and then 
specify its columns and their order to be displayed in 
the Packet view.

View Subcolumns This tab enables you to select a precool and then 
specify the fields and their order to be displayed in the 
Packet view.

Color This tab enables you to select a protocol and then 
specify a color ID for each of its packets.

OK Click OK to close the Preferences dialog box after 
saving the changes made in it.

Apply Click Apply to implement the changes made in the 
Preferences dialog box.

Cancel Click Cancel to close the Preferences dialog box 
without saving any changes.

Help Click Help to display online help.

Table 10 Components of the Preferences dialog box

Component Description
Setting Up Line Wrap and Time Format
To specify the line wrap and time format settings, use the 
General tab (Figure 13).

Table 11 briefly describes the components of the General 
tab.

Table 11 Components of the General tab

Component Description

Enable line wrap Select Enable line wrap limit the packet content to 
the display without extending the display to the right. 

Time format This section provides options to specify the time 
format to be used to display the timestamp details in 
the Packet view.
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Setting Columns
38
There may be a situation when, instead of all columns, you 
want to view only a few columns in the Packet view. You 
may also want to organize them in a particular order. To do 
all this, use the View Columns tab (Figure 14).

Figure 14 Preferences dialog box - View Columns tab

Table 12 briefly describes the components of the View 
Columns tab.

Table 12 Components of the View Columns tab

Component Description

Protocol Click the Protocol drop-down list to select a protocol 
whose Packet view display you want to change. 

Displayed fields The Displayed fields list box contains the columns that 
are displayed in the Packet view. 

Available fields The Available fields list box contains the columns that 
are not displayed in the Packet view. 

Move Down Click Move Down to move the selected column by one 
place down in the Displayed fields list box.

Move Up Click Move Up to move the selected column by one 
place up in the Displayed fields list box.

Select All Click Select All to move all the columns from the 
Available fields list box to the Displayed fields list box.
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Select Click Select to move the column you selected in the 
Available fields list box to the Displayed fields list box.

Deselect Click Deselect to move the column selected in the 
Displayed fields list box to the Available fields list box.

Deselect All Click Deselect All to move all the columns from the 
Available fields list box to the Displayed fields list box.

Table 12 Components of the View Columns tab

Component Description
Setting Subcolumns
Like columns, you can also choose to display only required 
sub columns and organize them in a particular order in the 
Packet view. To do this, use the View Subcolumns tab 
(Figure 15).

Figure 15 View Subcolumns tab

Table 13 briefly describes the components of the View 
Subcolumns tab.

Table 13 Components of the View Subcolumns tab

Component Description

Protocol Click the Protocol drop-down list to select a protocol 
whose Packet view display you want to change. 
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Hidden fields The Hidden fields list box contains the sub columns that 
are displayed in the Packet view

Available fields The Available fields list box contains the sub columns 
that are not displayed in the Packet view. 

Select All Click Select All to move all the sub columns from the 
Available fields list box to the Hidden fields list box.

Select Click Select to move the subcolony you selected in the 
Available fields list box to the Hidden fields list box.

Deselect Click Deselect to move the subcolony selected in the 
Hidden fields list box to the Available fields list box.

Deselect All Click Deselect All to move all the sub columns from the 
Hidden fields list box to the Available fields list box.

Table 13 Components of the View Subcolumns tab

Component Description
Setting Colors
The Preferences dialog box has the Color tab (Figure 16), 
which enables you to select a protocol and then specify a 
color ID for each of its packets. You generally do this to set 
separate colors for each packet to easily recognize them in 
the Packet view.

Figure 16 Color tab

Table 14 briefly describes the components of the Color tab.
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Table 14 Components of the Color tab

Component Description

Protocol Click the Protocol drop-down list to select a protocol 
whose Packet view display you want to change. 

Color Click Color to display the Color dialog box. In this 
dialog box, you can select a basic color or define a 
custom color.

Default Click Default to restore the default settings of the 
Color tab for the selected protocol.
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Marking Data Packets
42
In Protocol Analyzer, you can create markers to bookmark 
data packets in the Packet view. Creating markers help you 
to easily jump to the marked data packets, and to measure 
the time behavior between the marked data packets.

In Protocol Analyzer, you can create, edit, and delete 
markers.

In this section, you will learn:

• To Create a Marker

• To Edit a Marker

• To Jump to a Marker

• To Measure Time between Markers

• To delete a Marker
To Create a Marker
1 Select the data packet, for which you want to create a 
marker, in the Packet view.

2 Click Edit > New Marker.
To Edit a Marker

NOTE You can also create a new marker:

• By double-clicking on the left of a data packet’s expand (or collapse) 
button. 

• By right-clicking on the left of a data packet’s expand (or collapse) 
button, and then selecting the New Marker shortcut menu command.
1 Select the marker that you want to edit.

2 Click Edit > Marker Properties.

The Properties of marker dialog box appears (Figure 17).
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Figure 17 Marker dialog box

3 Do the followings as desired:

a Type in the new name of the marker in the Name text 
box.

b Specify the new position of the marker in the Position 
section. This section shows the position of the marker 
in nanoseconds (ns) from the Absolute, Trigger, Begin, 
or End points. Here, Absolute refers to zero (0), 
Trigger refers to the start of the trigger, Begin refers to 
the start of trace, and End refers to the end of trace.

c Specify the new foreground and background colors of 
the marker in the Colors section. This section has two 
buttons: Foreground and Background. Clicking these 
buttons display the Color dialog box, from where you 
can choose the desired foreground or background color.

d Type in a comment about the marker, if any, in the 
Comment text area.

e Click OK.
To Jump to a Marker
• Click Goto > Marker > Marker_Name.

Here, Marker_Name is the name of the marker to which 
you want to jump.

You can also click the  icon on the toolbar and 
jump to the desired marker by selecting it from the 
drop- down list.
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To Measure Time between Markers
44
1 Click anywhere on the Measurement area.

A shortcut menu appears.

2 Click the New measurement menu command.

The Properties of Measurement dialog box appears 
(Figure 18).

Figure 18 Properties of Measurement dialog box

3 Select the first maker from the From maker drop- down 
list.

4 Select the second marker from the To marker drop- down 
list.

5 Click OK.

The measurement time between the two specified markers 
is displayed in the Measurement area.

You can delete an exiting measurement by just clicking it on the 
To delete a Marker

NOTE
Measurement area, and then clicking the Delete shortcut menu command. 

 You can also delete all existing measurements by clicking anywhere on 
the Measurement area, and then clicking the Delete All menu command. 
1 Select the marker, which you want to delete, in the 
Packet view.

2 Click Edit > Delete Marker.

You can also delete a marker by right-clicking on the marker name, and 
NOTE
then selecting the Delete Marker shortcut menu command.
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Capturing, Filtering, and Finding the 
Data

About Setting Up the Hardware    46

About Capturing the Data    56

About Filtering and Finding the Data    57

This chapter provides information on how to capture data 
and to setup hardware to capture data for different 
protocols. This chapter also provides information on filters 
and how to create filters in Protocol Analyzer.
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About Setting Up the Hardware
46
Once you have set up Protocol Analyzer, you can start using 
it to capture the data. At this stage, Protocol Analyzer 
captures the data using the default hardware settings, such 
as default x1 link width.

There may be a situation when the default link width of 
Protocol Analyzer does not matches the negotiated link 
width of transmitter and receiver. This prevents Protocol 
Analyzer from properly decoding the data packets, which 
results in displaying the garbage data on the screen. To 
avoid this situation, always ensure that the link width of 
Protocol Analyzer is always same as the negotiated link 
width of transmitter and receiver. To do this, you can use 
the Hardware Setup dialog box (Figure 19). This dialog box 
also enables you to specify other hardware settings, such as 
trace memory size, clock source, and capture mode.

To access this dialog box:

• Click Capture > Hardware Setup.

The Hardware Setup dialog box appears (Figure 19).

Figure 19 Hardware Setup dialog box
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The Hardware Setup dialog box provides different set of 
options for different protocols.

In the following sections, you will learn about:

• Setting Up the Hardware for PCI Express

• Setting Up the Hardware for ASI

• Setting Up the Hardware for Fibre Channel
Setting Up the Hardware for PCI Express
Figure 20 displays the Hardware Setup dialog box for the 
PCI Express protocol.
 

Figure 20 Hardware Setup dialog box for PCI Express

As shown in Figure 20, the Hardware Setup dialog box for 
PCI Express has two tabs: General and 
Upstream/Downstream.

Table 15 briefly describes the components of the General 
tab.
47



48

4 Capturing, Filtering, and Finding the Data
Table 15 Components of the General tab

Component Description

Enable advanced 
setup

Select Enable advanced setup to display separate tabs 
for Upstream and Downstream. This enables you to apply 
different hardware settings for Upstream and 
Downstream.

Memory depth Click the Memory depth drop-down list to select the 
trace memory size. This drop-down list allows you to 
choose between 1 KB and 1 GB of trace memory size.
The default trace memory size is 1 MB.
Data upload time is directly proportional to the memory 
depth. Therefore, it is very important to carefully decide 
upon the memory depth requirements.

Spec revision Click the Spec revision drop-down list to select the 
revision number, 1.0 or 1.0a, of the PCI Express 
specification.

Capture Mode The Capture Mode drop-down list enables you to specify 
how you want to capture the data traffic in Protocol 
Analyzer. This drop-down list provides the following 
options:
• Standard: Analyzer can be used for all analysis 

purposes. If electrical idle is broken on a lane, the 
analyzer will resume capturing. This mode should be 
used in all cases except when debugging around 
electrical idle.

• Fast Sync: This mode is optimized to analyze around 
power-up, link-training, or L0s states, where faster 
reaction times of Analyzer are needed, and less focus 
is placed on signal integrity. The Analyzer will take 
less time to resume capturing after break of electrical 
idle, but there is a probability to record false errors.

Avail. sw package Displays the disabled check boxes of link width. A 
selected check box means the link width is available to 
you. A cleared check box means the link width is not 
available to you.

Link Width Displays the option buttons for the available link width. 
Here, select the link width that matches the negotiated 
link width of transmitter and receiver.
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Table 16 briefly describes the components of the 
Upstream/Downstream tab.

Clock source Displays the following option buttons:
• internal: Select internal to select an internal clock 

source. You should select this option button if the 
data rate is in the range of 2.5 GB/s +/- 300 ppm, no 
SSC is being used, and to capture power-on of 
power-off transitions of the system or device under 
test.

• external: Select external to select an external clock 
source. You should select this option button if the 
system or device under test uses SSC or is otherwise 
outside the 2.5 GB/s +/- 300 ppm range.

Probe Channel The Probe Channel drop-down list provides options for 
the available channels. Here, select a channel that 
matches the negotiated link width of transmitter and 
receiver. 
This drop-down list is available when you are using the 
ATCA probe board or the midbus footprint.

Reset Receiver Click Reset Receiver to reset the receiver circuit of 
Protocol Analyzer to the default state. Clicking this 
button deletes all the changes you made to the default 
state of the receiver circuit.

OK Click OK to close the Hardware Status dialog box after 
saving the changes made in it.

Apply Click Apply to assign the changes made in this tab to the 
hardware.

Cancel Click Cancel to close the Hardware Status dialog box 
without saving any changes.

Help Click Help to display online help.

Table 15 Components of the General tab

Component Description
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Table 16 Components of the Upstream/Downstream tab

Component Description

Descrambler Displays the following option buttons:
• Enabled: Selecting Enabled activates the de-scrambler 

algorithm. This algorithm is used to generate the 
de-scrambled packet stream from an incoming 
scrambled packet stream.

• Disabled: Selecting Disabled deactivates the 
de-scrambler algorithm. You generally select this 
option when DUT is transmitting the non-scrambled 
data. This is because selecting Disabled, when DUT is 
transmitting scrambled data, displays the garbage data.

• You generally select this option button when you do not 
want to de-scramble the scrambled packet stream.

Lane reversal Displays the following option buttons:
• On: Select On to activate lane reversal.
• Off: Select Off to deactivate lane reversal.

Polarity Reversal Displays the following option buttons: 
• Manual: Selecting Manual enables you to set the 

polarity of the individual lanes to the Normal or 
Inverted state.

• Automatic: Selecting Automatic sets the polarity of the 
lanes automatically during the initial link training.

Use physical lanes The Use physical lane drop-down list enables you to 
specify the number of physical lanes to use. This 
drop-down list provides the following options:
• 0 ... 7: Selecting 0 ... 7 maps 0 ... 7 physical lanes with 0 

... 7 channels of Protocol Analyzer.
• 4 ... 7: Selecting 4 ... 7 maps 4 ... 7 physical lanes with 4 

... 7 channels of Protocol Analyzer. If you select the x1, 
x2, or x4 lane width in the General tab, then selecting 4 
... 7 maps 0 ... 3 physical lanes with 0 ... 3 channels of 
Protocol Analyzer.

OK Click OK to close the Hardware Status dialog box after 
saving the changes made in it.

Apply Click Apply to assign the changes made in this tab to the 
hardware.

Cancel Click Cancel to close the Hardware Status dialog box 
without saving any changes.

Help Click Help to display online help.
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Setting Up the Hardware for ASI
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Figure 21 displays the Hardware Setup dialog box for the 
ASI protocol.
Figure 21 Hardware Setup dialog box for ASI

As shown in Figure 21, the Hardware Setup dialog box for 
ASI has two tabs: General and to System/to DUT.

Table 17 briefly describes the components of the General 
tab.

Table 17 Components of the General tab

Component Description

Enable advanced setup Select Enable advanced setup to display separate 
tabs for Upstream and Downstream. This enables you 
to apply different hardware settings for Upstream and 
Downstream.

Memory depth Click the Memory depth drop-down list to select the 
trace memory size. This drop-down list allows you to 
choose between 1 KB and 1 GB of trace memory size.
The default trace memory size is 1 MB.
Data upload time is directly proportional to the 
memory depth. Therefore, it is very important to 
carefully decide upon the memory depth requirements.
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Spec revision Click the Spec revision drop-down list to select the 
revision number, 1.0 or 1.0a, of the PCI Express 
specification. 

Capture Mode The Capture Mode drop-down list enables you to 
specify how you want to capture the data traffic in 
Protocol Analyzer. This drop-down list provides the 
following options:
• Standard: Analyzer can be used for all analysis 

purposes. If electrical idle is broken on a lane, the 
analyzer will resume capturing. This mode should 
be used in all cases except when debugging around 
electrical idle.

• Fast Sync: This mode is optimized to analyze 
around power-up, link-training, or L0s states, where 
faster reaction times of Analyzer are needed, and 
less focus is placed on signal integrity. The 
Analyzer will take less time to resume capturing 
after break of electrical idle, but there is a 
probability to record false errors.

Avail. sw package Displays the disabled check boxes of link width. A 
selected check box means the link width is available 
to you. A cleared check box means the link width is 
not available to you.

Link Width Displays the option buttons for the available link 
width. Here, select the link width that matches the 
negotiated link width of transmitter and receiver.

Clock source Displays the following option buttons:
• internal: Select internal to select an internal clock 

source. You should select this option button if the 
data rate is in the range of 2.5 GB/s +/- 300 ppm, 
no SSC is being used, and to capture power-on of 
power-off transitions of the system or device under 
test.

• external: Select external to select an external clock 
source. You should select this option button if the 
system or device under test uses SSC or is 
otherwise outside the 2.5 GB/s +/- 300 ppm range.

Probe Channel The Probe Channel drop-down list provides options 
for the available channels. Here, select a channel that 
matches the negotiated link width of transmitter and 
receiver. 
This drop-down list is available when you are using 
the ATCA probe board or the midbus footprint.

Table 17 Components of the General tab

Component Description
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Table 18 briefly describes the components of the to 
System/to DUT tab.

Reset Receiver Click Reset Receiver to reset the receiver circuit of 
Protocol Analyzer to the default state. Clicking this 
button deletes all the changes you made to the default 
state of the receiver circuit.

OK Click OK to close the Hardware Status dialog box after 
saving the changes made in it.

Apply Click Apply to assign the changes made in this tab to 
the hardware.

Cancel Click Cancel to close the Hardware Status dialog box 
without saving any changes.

Help Click Help to display online help.

Table 18 Components of the to System/to DUT tab

Component Description

Descrambler Displays the following option buttons:
• Enabled: Selecting Enabled activates the 

de-scrambler algorithm. This algorithm is used to 
generate the de-scrambled packet stream from an 
incoming scrambled packet stream.

• Disabled: Selecting Disabled deactivates the 
de-scrambler algorithm. You generally select this 
option when DUT is transmitting the non-scrambled 
data. This is because selecting Disabled, when DUT 
is transmitting scrambled data, displays the garbage 
data.

Lane reversal Displays the following option buttons:
• On: Select On to activate lane reversal.
• Off: Select Off to deactivate lane reversal.

Polarity reversal Displays the following option buttons: 
• Manual: Selecting Manual enables you to set the 

polarity of the individual lanes to the Normal or 
Inverted state.

• Automatic: Selecting Automatic sets the polarity of 
the lanes automatically during the initial link 
training.

Table 17 Components of the General tab

Component Description
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Use physical lane The Use physical lane drop-down list enables you to 
specify the number of physical lanes to use. This 
drop-down list provides the following options:
• 0 ... 7: Selecting 0 ... 7 maps 0 ... 7 physical lanes 

with 0 ... 7 channels of Protocol Analyzer.
• 4 ... 7: Selecting 4 ... 7 maps 4 ... 7 physical lanes 

with 4 ... 7 channels of Protocol Analyzer. If you 
select the x1, x2, or x4 lane width in the General tab, 
then selecting 4 ... 7 maps 0 ... 3 physical lanes with 
0 ... 3 channels of Protocol Analyzer. 

OK Click OK to close the Hardware Status dialog box after 
saving the changes made in it.

Apply Click Apply to assign the changes made in this tab to 
the hardware.

Cancel Click Cancel to close the Hardware Status dialog box 
without saving any changes.

Help Click Help to display online help.

Table 18 Components of the to System/to DUT tab

Component Description
Setting Up the Hardware for Fibre Channel
Figure 22 displays the Hardware Setup dialog box for the 
Fibre Channel protocol.

Figure 22 Hardware Setup dialog box for Fibre Channel

Table 19 briefly describes the components of the Hardware 
Setup dialog box for Fibre Channel.
Protocol Analyzer User Guide



Capturing, Filtering, and Finding the Data 4

Protocol Analyzer User Guide
Table 19 Components of the Fibre Channel dialog box

Component Description

Memory depth Click the Memory depth drop-down list to select the trace 
memory size. This drop-down list allows you to choose 
between 1 KB and 1 GB of trace memory size. The default 
trace memory size is 1 MB.

Limit payload to Select the Limit payload to check box if you want to limit 
the payload to a particular number of bytes. Selecting this 
check box enables the adjacent text box. Here, type in the 
number of bytes to which you want to limit the payload.

Port speed Click the Port speed drop-down list to select an 
appropriate speed for the port.
If you have multiple ports within a single module, then 
you can select one of the following combinations of port 
speed:
• 1 Gb/s and 2 Gb/s
• 2 Gb/s and 4 Gb/s
Note that a port speed combination of 1 Gb/s and 4 Gb/s 
in the same module is not possible. For this, you need to 
use two separate modules in your application.

Channel A Name Specifies the name of Channel A.

Channel B Name Specifies the name of Channel B.

OK Click OK to close the Hardware Status dialog box after 
saving the changes made in it.

Apply Click Apply to assign the changes made in the Hardware 
Status dialog box.

Cancel Click Cancel to close the Hardware Status dialog box 
without saving any changes.

Help Click Help to display online help.
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About Capturing the Data
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Once you have specified the desired hardware settings, you 
can start using Protocol Analyzer to capture the data.
Capturing the Data
To capture the data:

• Click Capture > Start.

You can also start capturing the data by clicking the  
icon on the toolbar.

Once the data of the size of trace memory is captured, 
Protocol Analyzer stops and the captured data is 
displayed in the Packet view.

You can also stop Protocol Analyzer by clicking the 
Capture > Stop menu command or by clicking the  
icon on the toolbar.
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In this section, you will learn about:

• Filtering the Data

• Finding the Data
Filtering the Data
When you capture the data, it is first stored in the trace 
memory. From there, it is displayed in the Packet view. 
There are situations when, instead of viewing the complete 
data, you want to view and analyze only a specific portion 
of data. For this, you want to display only the required 
portion of the data from the trace memory. To deal with this 
situation, Protocol Analyzer enables you to apply filters to 
the captured data.

A filter is a set of one or more conditions that you apply on 
the data stored in the trace memory of Protocol Analyzer. 
You do this to display a specific portion of data in the 
Packet view to analyze. For example, if you want to analyze 
only TLPs, then you can create a filter that displays only 
TLPs in the Packet view.

In Protocol Analyzer, you can create and apply filters using 
the Filter dialog box (Figure 23).

To access the Filter dialog box:

• Click View > Filter > Custom.

The Filter dialog box appears (Figure 23).
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Condition text box

Channel drop-down list
Boolean Operation drop-down list

Add/Remove Condition menu
58
Figure 23 Filter dialog box

Table 20 briefly describes the components of the Filter 
dialog box.

 
Table 20 Components of the Filter dialog box

Component Description

Conditions The Conditions list box displays a hierarchical list of 
predefined and user patterns. 
All patterns under the TLP Patterns, DLLP Patterns, 
Ordered Sets, Training Sequences folders are predefined 
patterns. These patterns are protocol specific. 
All patterns under the User Patterns folder are user 
patterns. These patterns are created by copying the 
predefined patterns to this folder, and then modifying 
them to match your requirements.

Port Selection The Port Selection list box displays a check box list of 
ports connected with the current instance of Protocol 
Analyzer.
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IF The IF section provides the following components to 
specify the filter criteria:
• Add/Remove Condition: This menu enables you to add 

a new condition criteria to the IF section, or remove an 
existing condition criteria from the IF section. Note that 
you can remove conditions only when the IF section 
has more than one condition criteria.

• NOT: This check box enables you to apply the logical 
NOT function to the pattern in the Condition text box.

• Condition: This text box contains a pattern that you 
drag and drop from the Conditions list box.

• Channel: This drop-down list provides options to 
specify which channel to include in the filter criteria. 
This drop-down list is displayed when you add a pattern 
in the Condition text box.

• Boolean Operation: This drop-down list provides 
options to apply the logical OR or AND functions to the 
filter criteria. This drop-down list is displayed for every 
new condition that you add using the Add/Remove 
Condition menu.

THEN The THEN drop-down list provides options that you can 
choose as an action to be taken when the filter criteria is 
met. This drop-down list has the following options:
• Keep: Selecting Keep displays all the packets, meeting 

the filter criteria, in the Packet view.
• Drop: Selecting Drop removes all the packets, meeting 

the filter criteria, from the Packet view.

Copy Click Copy to copy the selected predefined pattern in the 
User Pattern folder. You generally do this to further modify 
the copied pattern.
The Copy command button is available only when you 
select a predefined pattern in the Conditions list box.

Show Click Show to display the Show Condition dialog box for 
the selected predefined pattern. This dialog box displays 
the contents of the selected predefined pattern and also 
allows you to edit it.

Delete Click Delete to delete the selected user pattern folder.
The Delete command button appears only when you 
select a user pattern.

Edit Click Edit to display the Edit Condition dialog box for the 
selected user pattern. Here, you can make any 
modifications to the selected user pattern, as desired.

Filter Click Filter to apply the filter criteria on the data displayed 
in the Packet view.

Table 20 Components of the Filter dialog box

Component Description
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Reset Filter Click Reset Filter to remove the applied filter criteria from 
the data displayed in the Packet view.

Close Click Close to exit the Filter dialog box.

Help Click Help to display the online help.

Table 20 Components of the Filter dialog box

Component Description
NOTE The following procedure provides a step-by-step instructions to keep only 
TLPs and DLLPs, and filter out all other types of data packets from the 
Packet view. With little modification, you can use these steps to keep or 
filter out any type of packets in the Packet view.
To create and apply filter

1 Click View > Filter > Custom.

The Filter dialog box appears.

2 Expand TLP Patterns in the Conditions list box.

3 Drag Any TLP from the Conditions list box and drop it in 
the Condition text box.

4 Click the Add AND/OR condition below menu command 
from the Add/Remove Condition menu.

This adds a new condition criteria.

5 Select OR from the Boolean Operation drop- down list.

6 Expand DLLP Patterns in the Conditions list box.

7 Drag Any DLLP from the Conditions list box and drop in 
the newly added Condition text box.

8 Select Keep from the THEN drop- down list.

This creates the filter that will display the captured TLPs 
and DLLPs in the Packet view.

9 Click Filter.

This filters the data in the Packet view.

10 Click Close.
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Consider that you have captured and displayed all TLPs in 
the Packet view. Now, you want to look at the description of 
a particular type of TLP to analyze it. In this situation, you 
can search the desired data packet using the Find dialog box 
(Figure 24).

In Protocol Analyzer, the Find dialog box enables you to 
specify single or multiple conditions to find the required 
data packet in the Packet view.

To access the Find dialog box:

• Click Edit > Find.

The Find dialog box appears (Figure 24).
Figure 24 Find dialog box

Table 21 briefly describes the components of the Find dialog 
box.
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Table 21 Components of the Find dialog box

Component Description

Conditions The Conditions list box displays a hierarchical list of 
predefined and user patterns. 
All patterns under the TLP Patterns, DLLP Patterns, 
Ordered Sets, Training Sequences folders are 
predefined patterns. These patterns are protocol 
specific. 
All patterns under the User Patterns folder are user 
patterns. These patterns are created by copying the 
predefined patterns to this folder, and then modifying 
them to match your requirements.

Copy Click Copy to copy the selected predefined pattern in 
the User Pattern folder. You generally do this to further 
modify the copied pattern.
The Copy command button is available only when you 
select a predefined pattern in the Conditions list box.

Delete Click Delete to delete the selected user pattern folder.
The Delete command button appears only when you 
select a user pattern.

Show Click Show to display the Show Condition dialog box for 
the selected predefined pattern. This dialog box displays 
the contents of the selected predefined pattern and also 
allows you to edit it.

Port Selection The Port Selection list box displays a check box list of 
ports connected with the current instance of Protocol 
Analyzer.
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Enter Search 
Condition(s)

The Enter Search Condition(s) section provides the 
following components to specify the search criteria:
• Add/Remove Condition: This menu enables you to 

add a new condition criteria to the Enter Search 
Condition(s) section, or remove an existing condition 
criteria from the Enter Search Condition(s) section. 
Note that you can remove conditions only when the 
IF section has more than one condition criteria.

• NOT: This check box enables you to apply the logical 
NOT function to the pattern in the Condition text box.

• Condition: This text box contains a pattern that you 
drag and drop from the Conditions list box.

• Channel: This drop-down list provides options to 
specify which channel to include in the filter criteria. 
This drop-down list is displayed when you add a 
pattern in the Condition text box.

• Boolean Operation: This drop-down list provides 
options to apply the logical OR or AND functions to 
the filter criteria. This drop-down list is displayed for 
every new condition that you add using the 
Add/Remove Condition menu.

Find next Click Find next to find the next occurrence of the data 
packet that matches the search criteria.

Find prev Click Find prev to find the previous Torrance of the data 
packet that matches the search criteria.

Close Click Close to exit the Filter dialog box.

Help Click Help to display the online help.

Table 21 Components of the Find dialog box

Component Description
NOTE The following procedure provides a step-by-step instructions to find a 
particular type of TLP in the Packet view. With little modification, you can 
use these steps to find any other type of packets in the Packet view.
To find a data packet

1 Click the first data packet in the Packet view.

2 Click Edit > Find.

The Find dialog box appears (Figure 24).

3 Expand the TLP Patterns and Memory Read folders in 
the Conditions list box.
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4 Drag Any Memory Read from the Conditions list box and 
drop it in the Condition text box.

5 Click Find next.

This highlights the first data packet in the Packet view, 
which matches the search criteria.

6 Repeat Step 5 until you find the required data packet.

7 Click Close to exit the Find dialog box.
Protocol Analyzer User Guide



Agilent Protocol Analyzer
User Guide
5
Triggers

About Triggers    66

About creating a Trigger    75

About Trigger Limitations    78

This chapter introduces you with the concept of triggers in 
Protocol Analyzer. This chapter also provides information on 
creating and editing triggers.
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When you run Protocol Analyzer, it by default captures all 
the data packets it encounters, and saves them in the trace 
memory. However, there may be a situation when you don’t 
want to capture all the data in the trace memory. Rather, 
you want to perform one or more specific actions only when 
Protocol Analyzer encounters a particular type of data 
packets. To deal with this situation, Protocol Analyzer 
enables you to create triggers.

A trigger is a combined set of conditions and their 
associated actions. A trigger condition specifies Protocol 
Analyzer about the type of data it should locate in the 
traffic. A trigger action instructs Protocol Analyzer about 
the action to be taken when the trigger condition is met.

In Protocol Analyzer, you can create triggers using the 
Trigger Setup window (Figure 25).

In this section, you will learn about:

• Accessing the Trigger Setup Dialog Box

• Editing Trigger Conditions
Accessing the Trigger Setup Dialog Box
To access the Trigger Setup window:

• Click Capture > Trigger Setup.

The Trigger Setup window appears (Figure 25).
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State section

Add/Remove State menu

Add/Remove ELSE IF menu

Add/Remove Action menu

Action drop-down list
Protocol Analyzer User Guide
Figure 25 Trigger Setup window
67



68

5 Triggers
Table 22 briefly describes the components of the Trigger 
Setup window.

Table 22 Components of the Trigger Setup window

Component Description

Menu bar Provides the following menus:
• File: Provides the New, Open, and Save menu 

commands to create a new trigger configuration 
(*.trg) file, open an existing trigger configuration file, 
and save the current trigger configuration in a file.

• Edit: Provides the Edit Condition, Show Condition, 
Copy Condition, and Delete Condition menu 
commands. You can use these menu commands to 
edit, display, copy, and delete the selected condition.

• View: Provides the Sequence Overview, Conditions, 
Configurations, Port Selector, and Default Window 
Arrangement menu commands. You can use these 
menu commands to display or hide the Sequence 
Overview, Conditions, Configurations, and Port 
Selector panes.The View menu also provides the 
Default Window Arrangement menu command that 
you use to resort to the default arrangement of the 
Trigger Setup window.

• Help: Provides the Help menu commands that you 
can click to display the online help.

Toolbar Provides icons for the New, Open, and Save menu 
commands.

Conditions The Conditions pane provides components to select one 
or more predefined and/or user patterns to specify the 
trigger criteria.

Configurations The Configurations pane provides components to open, 
rename, or delete the trigger configuration file. This 
pane also enables you to save a selected trigger 
configuration file at a different location.

Port Selection The Port Selection list box displays a check box list of 
ports connected with the current instance of Protocol 
Analyzer.
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Default Action The Default Action drop-down list provides options to 
specify the default action to be taken when a trigger is 
run. This drop-down list provides the following options:
• No Action: Select this option to not take any action 

when the underlying trigger runs.
• Store Downstream: Select this option to store 

downstream packets when the underlying trigger 
runs.

• Store Upstream: Select this option to store the 
upstream packets when the underlying trigger runs.

• Store Downstream, Store Upstream: Select this 
option to store both the upstream and downstream 
packets when the underlying trigger runs.

Trigger Position The Trigger Position scroll bar enables you to specify 
what range of data you want to capture in the trace 
memory.
Assume that trace memory size is 10 MB. Now, you 
want that 25%, i.e. 2.5 MB, of the trace memory is filled 
with the data that occurred immediately before the 
trigger condition is met, and rest of the trace memory is 
filled with the data that occurred after the trigger 
condition is met. To do this, move the Trigger Position 
scroll bar to the point, where its left-side is measured as 
25% and its right-side is measured as 75%.

State The State section provides components to specify the 
trigger criteria.

Sequence Overview The Sequence Overview section displays the trigger 
conditions and the actions to be taken when the trigger 
conditions are met, in the form of the IF - ELSE IF - ELSE 
programming construct. This section has the following 
components:
• Show Conditions: Select Show Conditions check box 

to display the trigger conditions.
• Show Actions: Select Show Actions check box to 

display actions to be taken when trigger conditions 
are met.

OK Click OK to close the Trigger Setup window after saving 
the changes made in it.

Apply Click Apply to assign the changes made in the Trigger 
Setup window to the hardware.

Close Click Close to exit the Trigger Setup window without 
saving any changes.

Help Click Help to display online help.

Table 22 Components of the Trigger Setup window

Component Description
69



70

5 Triggers
Table 23 briefly describes the components of the Conditions 
pane.

Table 24 briefly describes the components of the 
Configurations pane.

Table 25 briefly describes the components of the State 
section.

Table 23 Components of the Conditions pane

Component Description

Conditions The Conditions list box displays a hierarchical list of 
predefined and user patterns.

Copy Click Copy to copy the selected predefined pattern in the 
User Pattern folder. 

Show Click Show to display the Show Condition dialog box for 
the selected predefined pattern. This dialog box displays 
the contents of the selected predefined pattern, and also 
allows you to edit it.

Delete Click Delete to delete the selected user pattern.

Edit Click Edit to display the Edit Condition dialog box for the 
selected user pattern. Here, you can make any 
modifications to the selected user pattern, as desired.

Table 24 Components of the Configurations pane

Component Description

Configurations The Configurations list box contains a list of most 
recently used trigger configuration files and a default 
trigger configuration file.

Open Click Open to open the trigger configuration file that you 
have selected in the Configurations list box.

Save As Click Save As to save the selected trigger configuration 
file at a new location and/or with a new name.

Rename Click Rename to convert the selected trigger 
configuration file name into an editable text. Then, type 
in the new filename, and press the <Enter> key to 
rename it.

Delete Click Delete to delete the selected trigger configuration 
file.
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Table 25 Components of the State section

Component Description

Add/Remove State The Add/Remove State menu enables you to add a new 
state or remove an existing state. Note that you can 
remove a state only when there are more than one state 
in the current trigger configuration file.

Add/Remove ELSE IF This Add/Remove ELSE IF menu enables you to add a 
new or remove and existing ELSE IF section. This 
section is same as the IF section.

IF The IF section provides the following components to 
enable you to specify the trigger conditions:
• Add/Remove Condition: This menu enables you to 

add a new condition criteria to the IF section, or 
remove an existing condition criteria from the IF 
section. Note that you can remove conditions only 
when the IF section has more than one condition 
criteria.

• NOT: This check box enables you to apply the logical 
NOT function to the pattern in the Condition text box.

• Condition: This text box contains a pattern that you 
drag and drop from the Conditions list box.

• Channel: This drop-down list provides options to 
specify which channel to include in the filter criteria. 
This drop-down list is displayed when you add a 
pattern in the Condition text box.

• Boolean Operation: This drop-down list provides 
options to apply the logical OR or AND functions to 
the trigger criteria. This drop-down list is displayed 
for every new condition that you add using the 
Add/Remove Condition menu.

• THEN: The THEN sub-section has Action and GOTO 
drop-down lists, and Add/Remove Action menu. The 
Action drop-down list provides a list of actions to be 
taken when the trigger condition is met. The 
Add/Remove Action menu provides options to add a 
new or remove an existing Action drop-down list 
from the THEN sub-section.

ELSE The ELSE section has Action drop-down list and 
Add/Remove Action menu. The Action drop-down list 
provides a list of actions to be taken when the trigger 
condition is not met. The Add/Remove Action menu 
provides options to add a new or remove an existing 
Action drop-down list from the ELSE section.
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GOTO The GOTO drop-down list provides a list of states, e.g. 
Start, State2, and so on. By selecting a particular state, 
you specify where to jump once the action has been 
taken. 
The GOTO drop-down list is displayed in the THEN 
sub-section and in the ELSE section, below the Action 
drop-down list. Also, the GOTO drop-down list is 
displayed only when a trigger has more than one state.

Table 25 Components of the State section

Component Description
Editing Trigger Conditions
There may be a situation when you want to include a 
predefined pattern in the trigger criteria. However, you want 
to make some modification to it before including it in the 
trigger criteria. To do this, copy the desired predefined 
pattern in the User Pattern folder, and then use the Edit 
condition dialog box (Figure 26) to make the desired 
modifications.

To access the Edit condition dialog box:

1 Select the desired user pattern in the conditions pane.

2 Click Edit.

The Edit condition dialog box displays (Figure 26).
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Figure 26 Edit condition dialog box

Table 26 briefly describes the components of the Edit 
Condition dialog box.

Table 26 Components of the Edit Condition dialog box

Component Description

Condition Name The Condition Name text box displays the name of the 
user pattern to be edited.

Field The Field column contains the names of the fields of a
data packet. The number of fields displayed in this 
column may differ for different data packets.
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Value The Value column contains an input component for 
each data field. You can specify the desired inputs in 
these components to edit the selected data packet. This 
column also contains a drop-down list and a calculator 
for input assistance. The drop-down list enables you to 
specify your inputs in hexadecimal, binary, or decimal 
format.
Clicking the calculator for input assistance displays the 
Input Assistant dialog box. Here, you can perform 
boolean operations over the hexadecimal, binary, and 
decimal values, and use the resulting value as the new 
value for the corresponding data packet field.

Length The Length column displays the maximum length of a 
field in bits, bytes, or DWords.

Dynamic Trigger 
Pattern

The Dynamic Trigger Pattern section enables you to 
trigger on packets, which you otherwise cannot capture 
with static pattern terms because the parts of the 
packet content are determined dynamically during run 
time.
To create a dynamic trigger pattern, you need to specify 
two conditions or pattern terms. The one pattern term 
(source) will match with a packet and provide some of 
the packet content as input to the second pattern term 
(Target).

OK Click OK to close the Edit Condition dialog box and save 
the changes made to the user pattern.

Apply Click Apply to assign the new settings to the user 
pattern.

Reset Click Reset to ignore the changes made to the user 
pattern in the Edit Conditions dialog box.

Close Click Close to close the Edit Condition dialog box.

Help Click Help to display the online help.

Table 26 Components of the Edit Condition dialog box

Component Description
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Consider that you want to create a trigger to capture all 
types of TLP memory read packets whose length is 4 DW. 
You also want that:

• It should by default store both upstream and downstream 
packets.

• It should also capture 20% of pre- triggered history and 
80% of post- triggered history.

• It should not take any action when the trigger condition 
is not met.

Using the trigger condition requirement mentioned above, 
you will learn:

• To Edit a Trigger Condition

• To Create a Trigger
To Edit a Trigger Condition
1 Select PCI Express > Predefined Patterns > TLP 
Patterns > Memory Read > Any Memory Read in the 
Conditions pane.

2 Click Copy.

This copies the Any Memory Read option to the User 
Patterns folder with a new name, e.g. Any Memory 
Read_2.

3 Select Any Memory Read_2 in the User Patterns folder.

4 Click Edit.

The Edit Condition dialog box for Any Memory Read_2 
appears.

5 Type in 4 as the last digit in the text box for the Length 
field.

Figure 27 shows how you can do this in the Edit 
Conditions dialog box.
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Figure 27 Edit Condition dialog box for Any Memory Read_2

6 Click Apply.

7 Click OK.
To Create a Trigger
1 Click File > New in the Trigger Setup window.

2 Select Store Downstream, Store Upstream from the 
Default Action drop- down list.

3 Move the Trigger Position scroll bar to the point, where 
its left and right sides are measured as 20% and 80%, 
respectively.

4 Expand the User Patterns folder in the Conditions text 
box.

5 Drag Any Memory Read_2 from the Conditions list box 
and drop it in the Condition text box.
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6 Select Default Action from the first Action drop- down 
list in the THEN sub- section.

7 Select Trigger from the second Action drop- down list in 
the THEN sub- section.

8 Select No Action from the Action drop- down list in the 
ELSE section.

9 Select Show Conditions and Show Actions check boxes in 
the Sequence Overview section.

This displays the trigger condition and the actions to be 
taken when the trigger condition is met, in the form of 
the IF ELSE programming construct.

10 Click Apply.

11 Click OK.

This completes your trigger creation activity. You can now 
run Protocol Analyzer to use this trigger. You can also 
choose to save this trigger in a trigger configuration file 
for later needs.
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In Protocol Analyzer, a trigger has some limitation. These 
limitations are properly highlighted by appropriate 
notification messages in the Trigger Setup window.

While creating a trigger, remember the following constraints:

• You can add maximum of eight states in a trigger.

• You can add any number of IF ELSE IF conditions.

• You can add maximum of eight patterns in a trigger.

• You can add maximum of one Training Sequence and 
Ordered Set pattern term.

• Using a Training Sequence and Ordered Set pattern term 
reduces the number of remaining pattern terms by one.

• Using Flag as a condition reduces the number of available 
pattern terms by one.

• You can add either Counter 1 or Timer 1 as a condition 
in a trigger.

• You can add either Counter 2 or Timer 2 as a condition 
in a trigger.

• You can add either Counter 1 or Timer 1 with Trigger In 
as a condition in a trigger.
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